Home > Lab Challenge 1 – Switch Config

Lab Challenge 1 – Switch Config

August 26th, 2014 in Lab Challenge Go to comments

In this lab you will config 4 switches which are interconnected with each other.

Four_switches_topology.jpg

In our simulator, you can only use “?’ with a space before for seeing the next keywords (for example: “spanning ?”, not “spanning?”). The simulator can be accessed via this link: http://www.rstut.com/final_flash/Four_Switches_Lab_1/Four_Switches_Lab_1.html.

Please let us know if you like this simulator or not so that we can continue making other simulators in the future. Any suggestion, recommendation, error reports are warmly welcomed!

We are still working to add more Lab Challenges like this. If you have any challenges, commands or suggestions please comment here or send an email to support@rstut.com. Every contribution is warmly welcome!

Comments (65) Comments
  1. Kmndoz
    August 27th, 2014

    Statement 12 is being marked incorrect and the command requested is : “switchport trunk encapsulation dot1q”

  2. Luccas Aguiar
    August 28th, 2014

    Statment 12
    switchport nonegotiate

    Hugs

  3. Anonymous
    August 28th, 2014

    Its relay good one.
    Thanks

  4. Silas Moyo
    August 28th, 2014

    Very good way to test and practise

  5. Anonymous
    August 28th, 2014

    Nice,

    Took a few tries to figure out that it only checks up to the first error. It would be nice if it could check all the answers at once so that one can immediately see which ones they got wrong.
    Not sure how to use the “?” yet.

  6. rstut
    August 28th, 2014

    @Anonymous: Thanks for your suggestion. You can only use the “?” after “space” to see the next options.

  7. Shadi
    August 29th, 2014

    Having a problem with statements 11 & 12 as they are both should be configured as “switchport nonegotiate” command and it is not taking it.

  8. Shadi
    August 29th, 2014

    ok for statement 11: switchport mode trunk” and statement 12 “switchport nonegotiate” I don’t know why, but if anyone has an explanation, please share it.

    thanks

  9. rstut
    August 29th, 2014

    @Shadi: Requirement 9 has two parts:
    1) Configure a dot1q trunk between Sw2 & Sw4 using Fa0/19 interfaces.
    2) These ports should not use DTP to negotiate a trunk

    So we need two commands.

  10. networker
    September 1st, 2014

    question 2 – why don’t these work?

    spanning-tree vlan 10 priority 0
    spanning-tree vlan 10 priority 4096

    spanning-tree vlan 10 root primary
    spanning-tree vlan 10 root secondary

    What is the answer?

  11. rstut
    September 2nd, 2014

    @networker: These statements are correct:
    spanning-tree vlan 10 root primary
    spanning-tree vlan 10 root secondary

    This question is missing the requirement “without using priority keyword”. Thanks for your information, we have just updated Q.2.

  12. random
    September 2nd, 2014

    its really good !!
    This is the best way to learn things!!

  13. ccna
    September 5th, 2014

    Q3 –
    what port path cost should be implemented?
    command should be: “spanning-tree vlan 10 cost xx”
    0? 1? 100?

  14. rstut
    September 5th, 2014

    @ccna: The command “spanning-tree vlan 10 cost xx” can only be used under interface mode. Also that command cannot guarantee Sw1 to be the root bridge.

  15. anto
    September 6th, 2014

    can any one pls send me the answer for all the question.. thanks

  16. Sensie
    September 6th, 2014

    it’s amazinnnnnnnnnnnnnnnng
    please make more like this .. it’s fun to solve and good review to our information ..
    you are keep getting better and better .. you are the best

    thanksssssssssssssssssssssss

  17. rookie
    September 6th, 2014

    this is excellent, keep doing stuff like this folks.
    this is best online practice lab stuff I ve ever seen … I am amazied.

    thanks a lot.

  18. Om
    September 6th, 2014

    Here are answers except for Question 4 –

    Answer 1: spanning-tree mode rapid-pvst
    Answer 2: spanning-tree vlan 10 root primary
    Answer 3: spanning-tree vlan 10 root secondary
    Answer 4: ?????
    Answer 5: spanning-tree portfast
    Answer 6: channel-group 1 mode on
    Answer 7: switchport trunk encapsulation dot1q
    Answer 8: switchport mode trunk
    Answer 9: switchport mode dynamic auto
    Answer 10: switchport mode dynamic desirable
    Answer 11: switchport mode trunk
    Answer 12: switchport nonegotiate

  19. sunilks
    September 7th, 2014

    Question 4

    can we user SPANNING-TREE ROOTGUARD

    ???

  20. sunilks
    September 7th, 2014

    got answer for Q4

    spanning-tree guard root

  21. rstut
    September 7th, 2014

    @Om, @sunilks: Nice, congrats to solve all the requirement! We are going to upload Challenge 2!

  22. Mostafa
    September 11th, 2014

    Please post more labs then we can save money and appreciated for your hard work.

  23. kuprezak
    September 19th, 2014

    Hello guys!

    First of all I want to thank you for this nice simulator!
    In question nr. 9 is mistake…the question is:
    “Configure a dot1q trunk between SW2 and SW4 using interface F0/21; these ports should not use DTP to negotiate a Trunk.”
    The problem is that there is no connection via F0/21 between SW2 and SW4. It is only “cosmetic” issue but please correct this question. Thanks.

    Have a nice day.

  24. rstut
    September 19th, 2014

    @kuprezak: Thanks for your detection! We have just fixed it!

  25. Anonymous
    September 19th, 2014

    Great lab!!! I loved it!!!

  26. Ageu
    September 21st, 2014

    4- spanning-tree guard root

  27. FEE
    September 25th, 2014

    Great job !!!
    Gratz for that, is very usefull.
    Thanks

  28. nuttyprof
    October 7th, 2014

    love this sim, pls make more

  29. nitro.power
    October 19th, 2014

    4. spanning-tree portfast

  30. switchfreak
    November 7th, 2014

    Very nice sim…..thank you!

  31. bingobongo
    November 15th, 2014

    spanning-tree guard root

  32. perfect
    November 26th, 2014

    statement1:spanning-tree mode rapid-pvst
    statement2:spanning-tree vlan 10 root primary
    statement3:spanning-tree vlan 10 root secondary
    statement4:spanning-tree guard root
    statement5:spanning-tree portfast
    statement6:channel-group 1 mode on
    statement7:switchport trunk encapsulation dot1q
    statement8:switchport mode trunk
    statement9:switchport mode dynamic auto
    statement10:switchport mode dynamic desirable
    statement11:switchport mode trunk
    statement12:switchport nonegotiate

  33. Shekhar Suman
    December 1st, 2014

    It is very useful for the practice. Thanks all of the Engineers for there In Puts.

  34. stringbender
    December 11th, 2014

    Thank you for the simulator. I had to work harder than I ‘d like to admit to figure it out! LOL
    One correction, Question 5 references interfaces fa0/23 and fa0/24 but then specifies fa0/19 and fa0/20 in the range command. I believe this needs to be corrected.

  35. rstut
    December 12th, 2014

    @stringbender: Thanks for your detection. We have just updated it!

  36. Ioannis
    December 20th, 2014

    Very good job. Excellent for practice test!

    Thanks guys

  37. NB
    January 4th, 2015

    Awesome efforts, Hats off!!!!!!!!!!!!

  38. bisingi
    January 8th, 2015

    Wonderful job. if there is a way to do it with Gns3

  39. bisingi
    January 8th, 2015

    please, lets put on all sections ,even routing ( routers ) , wonderful site

  40. Chouven
    January 10th, 2015

    What’s Switch that Use for what? Use Cisco or Enterprise or shop Company

  41. Aslam Paikkarathodi
    January 13th, 2015

    plz send to aslam.paikkarathodi@railwire.co.in about the Training in real time networking of Switches by figures

  42. RY
    January 20th, 2015

    this is great!! thank you 🙂

  43. Andrew
    January 21st, 2015

    This is a great lab, thank you all for putting this together. Much appreciated

  44. Sudhansu Patel
    January 25th, 2015

    …………………Nice One………………….Thank You Very Much……………………………..

    1.spanning-tree mode rapid-pvst
    2.spanning-tree vlan 10 root primary
    3.spanning-tree vlan 10 root Secondary
    4.spanning-tree guard root
    5.spanning-tree portfast
    6.channel-group 1 mode on
    7.switchport trunk encapsulation dot1q
    8.switchport mode trunk
    9.switchport mode dynamic auto
    10.switchport mode dynamic desirable
    11.switchport mode trunk
    12.switchport nonegotiate.

    All statements are correct! Congratulations!

  45. grendel
    February 9th, 2015

    I love you guys

  46. Chez
    March 6th, 2015

    Thank you for this. I do not do this every day any more and need this type of stimulation to help me. I look at the comments and the questions, go to the book and read the chapters to re enforce the correct answers. I still need to keep my Certs current so with out this type of tool to assist my study effort with out the actual hardware access makes it difficult. Does this make sense?

  47. Fadhil
    March 21st, 2015

    Question No – 04.

    In this question its says its connecting for a router. It should be a end devices rt ? we configure portfast to a end devices. (pc-host) ?

  48. sonarru
    May 3rd, 2015

    Thank you, guys. You are doing awesome job!!!

  49. ALaa
    July 10th, 2015

    (4) : spanning-tree guard root

  50. Gwen07
    July 23rd, 2015

    Very excellent simulator.Please post so much more!!!!

    Thanks a million

  51. shameer
    November 10th, 2015

    hi everyone im preparing for switch exam in sha allah i’m going to sit the exam next week make dua in sha allah

    1#spanning-tree mode rapid-pvst
    2#spanning-tree vlan 10 root primary
    3#spanning-tree vlan 10 root secondary
    4#spanning-tree guard root
    5#spanning-tree portfast
    6#channel-group 1 mode on
    7#switchport trunk encapsulation dot1q
    8#switchport mode trunk
    9#switchport mode dynamic auto
    10#switchport mode dynamic desirable
    11#switchport mode trunk
    12#switchport nonegotiate

  52. Ipman
    January 3rd, 2016

    Hey guys, What´s going on with this website?? Where is the entire material??
    I´m planning to sit on CCIE written by end of 2016 and Lab by next year…

  53. Anonymous
    January 4th, 2016

    Hey guys, here 2 labs full configured for CCIE R&S and SP

    http://cafecomredes.blogspot.com.br/2015/12/labs-ccie-r-e-sp-prontos-pra-estudar.html?view=classic

    Regards

  54. Nuts
    January 16th, 2016

    Why use a spanning tree command on a port that a router is connected to? 4 is wrong it is not gaurd root.
    The configuration of root guard is on a per-port basis. Root guard does not allow the port to become an STP root port, so the port is always STP-designated. If a better BPDU arrives on this port, root guard does not take the BPDU into account and elect a new STP root. Instead, root guard puts the port into the root-inconsistent STP state. You must enable root guard on all ports where the root bridge should not appear.

  55. Anonymous
    February 27th, 2016

    Thank you for providing this and other practice items.

  56. Ageu
    March 4th, 2016

    1 spanning-tree mode rapid-pvst

    2 spanning-tree vlan 10 root primary
    spanning-tree vlan 10 root primary

    3 spanning-tree guard root

    4 spanning-tree portfast

    5 channel-group 1 mode on

    6 switchport trunk encapsulation dot1q

    7 switchport mode trunk
    switchport mode dynamic auto

    8 switchport mode dynamic desirable

    9 switchport mode trunk
    switchport nonegotiate

  57. Anonymous
    August 2nd, 2016

    please add AAA dot1x simmulator

  58. vikram Divekar
    October 10th, 2016
  59. Mian
    February 8th, 2017

    Any one have lates .VCE files for switching please share t on
    m.awais1979 @ yahoo.co.uk

  60. Traivs Lai
    February 9th, 2017

    @vikram Divekar

    Thanks for sharing 400-101 Lab dumps!

    I finally passed my 400-101 Lab exam two days ago!

    Mainly learned that PassLeader 400-101 Lab study materials, including Troubleshooting, Lab Configuration, Diagnostic…etc.

    BTW: PassLeader’s TS Track and Notes really helpful!!!

    Good Luck!

  61. pato
    March 8th, 2017

    @Traivs Lai
    can you share me the pdf please!!

  62. CCIE
    March 28th, 2017

    Hi Guys,

    Is anyone interested in discussing the CCIE R&S dumps.

    Skpe id – asha02839

  63. May
    April 24th, 2017

    the new lab dump is valid or not .
    but i find some thing about lab.

  64. Hyatt Regency
    July 11th, 2017

    Has anyone taken then the Switching Exam Lately and know anything that is on it like the LABS or Questions and Answer

  65. binary bit boy
    August 10th, 2017

    very cool lab challenge

Add a Comment